Merchant Interface Login - Password Expiration Change
Incident Report for Authorize.net
Resolved
This change has been completed. Please do not hesitate to contact the Authorize.net support team if you have any questions or concerns.

Authorize.net Support Center
Posted Nov 28, 2023 - 15:49 UTC
Monitoring
Starting on October 30, 2023, Authorize.net will be moving from 120-day expiration to a 90-day expiration period to enhance login and account security.

Please do not hesitate to contact the Authorize.net support team if you have any questions or concerns.

Authorize.net Support Center
Posted Oct 30, 2023 - 15:14 UTC
This incident affected: Portals (Access/Login - Merchant Interface/Portal).